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AdventureWorks Module 1: Getting Started 
 

Objectives 
 

After completing this lab, you will be better able to: 

� Deploy a web part using the Visual Studio extensions 

� Explore Adventure Works using SharePoint Designer 2007 

Scenario 
The purpose of this lab is to introduce you to the Adventure Works site, where 

you will explore some common interface elements used throughout the site such 

as login/registration controls and search. You will also explore Central 

Administration in order to gain an understanding as to how the site is configured. 

You will then use the Visual Studio Extensions for Windows SharePoint 

Services v1.2 to deploy a custom web part to the Adventure Works site.  

Estimated Time to 

Complete This Lab 

 

60 Minutes 

Computers used in this 

Lab 
  Image014-5 

    

The password for the Administrator account on all computers in this lab is: 

pass@word1 
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Exercise 1 

Adventure Works Walkthrough 
 

Scenario 

In this exercise, you will be taken around the Adventure Works site to explore it’s interface elements. 

 

Tasks Detailed Steps 

Complete the following 

tasks on: 

 Image014-5 

1. Register a new user 

account in 

Adventure Works 

Note: The Adventure Works SharePoint web application provides two entry points; a 

private authoring site which uses Windows Authentication 

(http://authoring.adventure-works.com) and a public facing web site which uses 

Forms Based Authentication (http://www.adventure-works.com). 

a. Open Internet Explorer and browse to the Adventure Works homepage: 

http://www.adventure-works.com 

Note: Notice that this is the public entry point for Adventure Works and is running 

under Forms Based Authentication. 
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Note: The Adventure Works homepage features a Register panel which facilitates self 

service member registration. A link to registration is also present in the top navigation 

of the site. 

 

b. Click on the Register button on the homepage to navigate to the registration page. 

c. On the registration page, fill in all the details and click Register to create an 

account on the site. 

� Name: labuser 

� E-mail: labuser@adventure-works.com 

� Password: pass@word1 

Note: If the registration is successful you will see a Thank you page indicating that 

the account has been created. 

d. Close and re-open the browser or hit logout button.  

2. Login using new 

account 

Note: Now that you have registered, you can login with your new account. 

a. Browse to the Adventure Works homepage (http://www.adventure-works.com). 

b. Login to the site with the same account you just registered in the previous task. 
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Tasks Detailed Steps 

Note: Notice the homepage now displays a personalized profile view in place of the 

login box. 

3. Explore My 

Adventure Works 

Note: Adventure Works provides a personal profile page and My Site integration, 

which is called My Adventure Works. 

a. Click on the My Adventure Works link in the top navigation. 

Note: When you click on this link, SharePoint will create you a new My Site site 

collection. Adventure Works uses the My Site functionality in order to provide users 

with a personal picture gallery, blog and other features such as messages. 

Note: Once the My Site has been created, you will be redirected to your My Adventure 

Works homepage. 

Note: The My Adventure Works homepage exposes a number of social networking 

features, some are based on out of the box SharePoint features and others are custom 

features. 

The personal details information is store in the Shared Service Provider. My Buddies 

is actually using the SharePoint Colleagues functionality. My Messages uses a custom 

list in the user’s My Site site collection and My Gallery uses the image gallery 
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document library in the My Site. 

These features will be covered in greater detail in Module 9: Enabling social 

networking for your site. 

4. Explore the 

Silverlight 

application 

a. Browse to the Adventure Works homepage (http://www.adventure-works.com). 

Note: On the homepage, there is a Silverlight control featured to the top right of the 

page. The control provides a gallery viewer which is dynamically powered via content 

from the site. 

b. Click on one of the thumbnail images on the right of the control and observe that 

the large image background changes accordingly. The Silverlight application is 

displaying pictures from the gallery at http://www.adventure-works.com/galleries. 

c. Click on the Go To Picture Gallery link and explore the Gallery. 

d. Return to the homepage and in the Silverlight application, click on the Go To 

Destination guide link. 

Note: Destination Guides showcase some common WCM functionality. The default 

page (overview) and other section pages feature numerous content placeholders which 

can be edited by the user. The user is also able to upload and display images on the 

pages. 

In the right column of the page there is an image placeholder at the top followed by a 

custom control which aggregates the latest chat messages about the current 

destination from the discussion boards (http://www.adventure-

works.com/community/Lists/Discussion%20Board/AllItems.aspx). 
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The Other Destinations area uses a Content Query WebPart to display an aggregated 

view of the two most recently updated Destination Guides. 

5. Add a new 

Destination Guide 

Note: The Adventure Works site provides a site template for creating new Destination 

Guides. You will utilise this site template now. 

a. Navigate to the authoring site (http://authoring.adventure-works.com). 

b. As this site is using Windows Authentication, you will be logged when you try to 

access a system page. 

Note: Do this now by browsing to http://authoring.adventure-

works.com/_layouts/settings.aspx 

c. When you are prompted to login in, login as the site administrator: 

� Username: litwareinc\administrator 

� Password: pass@word1 

Note: Once logged in you should see the Site Actions menu appear beneath the search 

box to the top right of the page. 

d. In the Destination Guides section of the homepage, click on Scotland. 

e. Click on Site Actions > Create Site. 
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f. In the Title and Description section, change the title to Glasgow, and in the Web 

Site Address section change the URL name to glasgow. Under the Template 

Selection, ensure that Adventure Works Destination Guide Site is selected in the 

publishing tab, and then click Create at the bottom of the page. 
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Tasks Detailed Steps 

g. Wait while SharePoint creates the new site. 

 

h. Once completed, you should see the Overview page for the new site. At this point 

the page is in an unpublished state. 

 

i. Click on the Edit Page button in the Page Editing Toolbar to switch to edit 

mode. 

j. Populate the page fields with some content. 

 

k. To add a picture to the location images or the main page image on the right, click 

on Click to add a new picture on any of the image placeholders. This will bring 

up the Edit Image Properties dialog. 
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l. Click on Browse… to pick a picture from a SharePoint gallery. 

 

m. Click on an image and click OK when done to return to the Edit Image Properties 

dialog. Here you be able to specify additional image properties such as Alternate 

text before adding the image to the placeholder. 
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Tasks Detailed Steps 

Note: Some fields on the page, such as Page Content allow rich content and 

formatting. Clicking on this field will automatically bring up the RadEditor Lite 

toolbar. RadEditor Lite is a free third party solution from Telerik 

(http://www.telerik.com/products/sharepoint/lite-editor-for-asp.net.aspx) which is 

being used instead of the standard out-of-the-box editing toolbar that MOSS provides. 

This is due to the enhancements it provides when saving content as XHTML 

compliant. 

n. When you’ve finished editing the page, click the Publish button in the Page 

Editing Toolbar. 

Note: This will publish the page so it is no longer in a draft state and other users will 

be able to see the content. 

o. The published Overview page is just one of four pages, which makes up a 

Destination Guide. The other pages are Getting Around, Things To Do and 

Maps. 

 

6. Use the Adventure 

Works site search 

Note: The search box is available on all pages of the site as it is included in the 

Adventure Works default master page. The search box is located to the top right of the 

page. 

a.  Place the cursor inside the search box and enter Scotland and then click the 

Search button. 
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Note: You will be redirected to the search results page and you should see some 

results for the query. The search results page uses some of the out-of-the-box 

SharePoint web parts which provide the results display, pagination and also the 

ability to sort the results by Modified Date or Relevance. 

 

7. Examine the site 

content and 

structure 

a. Select Site Actions > Manage Content and Structure 
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Tasks Detailed Steps 

 

Note: This will bring up a view of the structure of the Adventure Works site collection. 

You will see that the various sub-sites define the top level site structure that is used in 

the top navigation. Note that each sub-site has its own pages library. 

8. Explore the IIS 

configuration 

Note: In this task, you will begin exploring the server configuration in order to 

understand how the Adventure Works site is set up. 

a. Open the IIS Manager: Start Menu > Administrative Tools > Internet 

Information Services (IIS) Manager 

b. Select the Web Sites node to display the details of each web site. 
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Tasks Detailed Steps 

 

Note: The SharePoint Central Administration v3 web site is running on port 6147. 

You can navigate to the Central Administration site from the Start Menu. 

Also note that AdventureworksProduction and AdventureworksAuthoring are using 

host headers which you will use to browse to those web sites. 

c. Close Internet Information Services (IIS) Manager. 

9. Explore Central 

Administration 

Note: You will now begin to explore the SharePoint configuration via Central 

Administration. 

a. Open Central Administration: Start Menu > Administrative Tools > SharePoint 

3.0 Central Administration  

b. When prompted, log in as litwareinc\administrator using password 

pass@word1. 

c. Click on the Operations tab. 

d. Select Global Configuration > Solution management. 

Note: There are a number of extra solution packages present which are deployed 

during the Adventure Works installation. 

e. Click on the Application Management tab. 

f. Select SharePoint Web Application Management > Web application list. 

 

Note: There are a number of SharePoint web applications present in the farm. 

AdventureworksAuthoring (the Adventure Works site) and ssp.adventure-works.com 

(the Shared Service Provider used for Adventure Works) are created by the Adventure 

Works installer. 

g. Click the Cancel button. 

h. Select Application Security > Authentication providers and if necessary ensure 

http://authoring.adventure-works.com is the selected web application. 
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Tasks Detailed Steps 

 

Note: The Adventure Works web application uses two zones. The Default zone and the 

Internet zone. 

i. Click on the Internet zone. 

Note: This zone is configured to use forms based authentication via the fbaMembers 

membership provider and fbaRoles role manager. Anonymous access is enabled for 

this zone. 

j. Click the Cancel button and then click on the Default zone. 
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Note: This zone is configured to use Windows authentication via NTLM, and 

anonymous access is enabled. 

10. Explore the 

Adventure Works 

Shared Services 

provider 

Note: Adventure Works uses it’s own Shared Service Provider which is created during 

the install process. You will explore this now. 

a. Click on the ssp.adventure-works.com link in the quick launch panel on the left. 

 

b. Select User Profiles and My Sites > View profile properties. 

c. Click on User Profile Properties > View profile properties. 

d. Scroll to the foot of the properties page to the Adventure Works Properties section. 

This section contains two custom properties, Country and Gender. 
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e. Return to the Shared Service Provider homepage. 

f. Select User Profiles and My Sites > Personalization service permissions. 

Note: Notice the Forms based authentication specific users are granted permissions 

here 

 

g. Close Internet Explorer. 
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Exercise 2 

Development Tools and Web Part Solution 
 

Scenario 

In this exercise, you will deploy a web part using the Visual Studio extensions for Windows SharePoint Services 

(VSeWSS) v1.2 and explore Adventure Works using SharePoint Designer 2007. 

 

Tasks Detailed Steps 

Complete the following 

tasks on: 

 Image014-5 

1. Create and deploy a 

web part 

Note: First of all, you will create and deploy a new web part using the VSeWSS 1.2 in 

Visual Studio 2008. 

a. Open Microsoft Visual Studio 2008 from Start | Programs | Microsoft Visual 

Studio 2008 | Microsoft Visual Studio 2008 

b. In Visual Studio, select File > New > Project… 

c. Expand the Visual C# node and click on Sharepoint, then click WebPart under 

Templates. 

d. Change the project name from WebPart1 to AdventureWorks.WebParts, and 

click OK. 

 

Note: The project created contains a folder called WebPart1, which contains 3 files 

also called WebPart1. For this demo, you will change the name of the web part to 

something more relevant - HelloWorld. 

e. Right-click the WebPart1 folder, and select Delete. Click OK on confirm dialog 

box. 

f. Right-click the project name AdventureWorks.WebParts in the Solution 

Explorer window, and select Add > New Item… 

g. In the Add New Item window under Visual C#, click on SharePoint, then select 

the Web Part item and rename WebPart1 to HelloWorld. 

h. Click Add. 
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Note: HelloWorld.cs is the web part control, and will be the location of the code to 

display some text on the screen. 

HelloWorld.webpart is the xml which defines the web part. 

HelloWorld.xml is the xml which tells SharePoint what the feature consists of and 

where it should be located. 

i. Open the HelloWorld.webpart file, and update the title and description. E.g. 

<property name="Title" type="string">Hello World Web 
Part</property> 

<property name="Description" type="string">Hello World 
Example</property> 

j. Save and close the file. 

k. Open the HelloWorld.cs file, and uncomment the following lines: 

// Label label = new Label(); 

// label.Text = "Hello World"; 

// this.Controls.Add(label); 

l. Save and close the file. 

m. Right-click the project name AdventureWorks.WebParts in the Solution 

Explorer window, and select Properties. (If you don’t have the Solution 

Explorer visible, go to View > Solution Explorer.) 

n. In the main window along the left column, select the Debug tab, and change the 

Configuration dropdown to All Configurations. 

o. Under the Start Action section, make sure the Start browser with URL option is 

selected and update the URL to http://authoring.adventure-works.com/. 

p. Switch to Debug mode in the Configuration drop-down.. 

q. Right-click the solution name Solution ‘AdventureWorks.WebParts’ (1 project) 

in the Solution Explorer window, and select Deploy. (You can access the same 

command via Build  | Deploy Solution from the main menu bar.) 

r. If success, you should see Deploy succeeded in the status at the bottom left of the 

Visual Studio screen. 

s. Minimize Visual Studio. 

t. Confirm the solution has been successfully deployed. Open SharePoint Central 

Administration: Start | | SharePoint 3.0 Central Administration 

u. Select the Operations tab. Under the Global Configuration section, select 

Solution Management. 
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v. Confirm adventureworks.webparts.wsp marked as Deployed. 

 

2. Add a web part to a 

web part page 

Note: Now that the web part has been deployed to the farm, it needs to be added to a 

page in the Adventure Works site. 

a. Open a new browser and navigate to http://authoring.adventure-

works.com/_layouts/settings.aspx. 

b. Login in as litwareinc\administrator with password pass@word1 (you may be 

already logged-in). 

c. The Site Actions menu should appear in the top right hand corner. 

d. Select Site Actions | Create Page. 

e. On the Create Page, add the following values. When these have been added, click  

Create.  

Title: Hello World 

Description: (optional) 

URL Name: Pages/wpp.aspx 

Page Layout: (Welcome Page) Blank Web Part Page 

f. Pick a zone, such as the Header, and click on the Add a WebPart button.  

 

g. On the Add Web Parts window, scroll down to the Miscellaneous section, where 

you should see the HelloWorld Web Part. 
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h. Check the checkbox beside the HelloWorld Web Part, and click Add. 

i. When the web part has been added, click the Publish button on the page editing 

toolbar. 

 

Note: The page now displays the new web part. 

3. Retract the solution 

and remove the web 

part 

Note: Next you will make some modifications to the web part, but first you will remove 

the web part from the farm. 

a. Open Command Prompt: Start | Run… | cmd 

b. At the prompt, type:\ 

cd C:\Documents and Settings\Administrator\My 
Documents\Visual Studio 
2008\Projects\AdventureWorks.WebParts\ 
AdventureWorks.WebParts\bin\Debug 

Note: (If you put your project in a different location, change the path to match 

location of your project) 

VSeWSS has created a setup.bat file which you can use to install and uninstall the 

solution. 

c. To view the help, type: 
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Setup.bat /? 

 

 

 

 

d. Now uninstall the solution by typing: 

Setup.bat /uninstall 

 

Note: Although this has removed the solution, the web part is still in the gallery and 

will cause an error on the web page. 

e. Browse to http://authoring.adventure-works.com/_layouts/settings.aspx 

f. Login as administrator if you are prompted. 
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g. Browse to http://authoring.adventure-works.com/pages/wpp.aspx. 

h. Select Site Actions | Edit Page. 

i. In the menu bar of the problem web part, select edit | Delete. Click OK on the 

confirm dialog box. 

j. Add ?contents=1 to the end of the URL to get to the web part maintenance page. 

http://authoring.adventure-works.com/pages/wpp.aspx?contents=1 

k. If there is a checkbox for “Error,” check it and click the Delete button. 

l. Next, select Site Actions | Site Settings | Modify All Site Settings. 

m. On the Site Settings page, under the Galleries section, select Web Parts. 

n. You should see the HelloWorld.webpart still listed. Click the Edit icon to the 

right. 

o. Click the Delete Item button, and click the OK button on the confirm dialog box. 

Note: You can remove the web part from the page and the gallery before running the 

uninstall. 

4. Add a property to 

the web part 

Note: Now that the web part has been fully undeployed, you can make some 

modifications. 

a. Re-open Microsoft Visual Studio 2008: Start | Programs | Microsoft Visual 

Studio 2008 | Microsoft Visual Studio 2008 

b. Select AdventureWorks.WebParts from the Start Page Recent Projects section. 

c. Open the HelloWorld.cs file. 

d. Add the following code block before the constructor (public HelloWorld() 

{ }) 

private const string defaultGreeting = "Hello 
Universe"; 

private string greeting = defaultGreeting; 

  

[WebBrowsable(true),  

SPWebCategoryName("AdventureWorks"),  

Personalizable(PersonalizationScope.Shared)] 

public string Greeting 

{  

    get { return greeting; } 

    set { greeting = value; } 

} 

e. In the same file, change the value for label.Text to greeting: 

label.Text = “greeting”; 

f. Save and close the file. 

g. Ensure you have uninstalled any previous installs of the 

AdventureWorks.WebParts.wsp solution, and that you have tidied up the web 

part page and the web part gallery (see previous task). 

h. Right-click the solution name Solution ‘AdventureWorks.WebParts’ (1 project) 

in the Solution Explorer window, and select Deploy. 

i. Browse to http://authoring.adventure-workscom/pages/wpp.aspx. 

j. Select Site Actions > Edit Page (if the Site Actions menu has disappeared, login 

again). 



Module 1: Getting Started 

 

Page 23 of 24 

Tasks Detailed Steps 

k. Click on the Add a Web Part button. 

l. On the Add Web Parts window, scroll down to the Miscellaneous section, select 

the Hello World Web Part, and click Add. 

m. For the web part, select edit | Modify Shared Web Part. 

 

n. In the Hello World Web Part panel in the right column, expand the 

AdventureWorks section. 

 

o. Update the text for the Greeting, and click OK. 

p. The text has updated. Finish off by clicking the Publish button. 

5. Explore Adventure 

Works using 

SharePoint Designer 

2007 

Note: Now you will browse the Adventure Works site structure using SharePoint 

Designer 2007. 

a. Select Start Menu | All Programs | Microsoft Office | Microsoft Office 

SharePoint Designer 2007. 

b. In SharePoint Designer, select File > Open Site … 

c. Enter http://authoring.adventure-works.com into the site name box and click 

Open. 

Note: When using SharePoint Designer, always use the Windows authentication 

version of the site, otherwise you may encounter problems. 

d. If prompted, login as litwareinc\administrator, password pass@word1. 

e. In the Folder List window, you can see the site structure. Expand the Pages 
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folders, and double-click default.aspx. 

Note: You will receive a warning that publishing pages cannot be edited in SharePoint 

Designer. 

f. Click the Edit Page Layout button. 

g. In the check out prompt, click the Yes button. 

Note: SharePoint Designer retrieves the page layout that the publishing page is using, 

checks it out and opens it for editing. 

The AWHomePage.aspx will open in the main screen, and the file will have a green 

tick to mark it as checked out. 

 

h. To check in the file with changes, right-click default.aspx, and select Check In. 

Note: You can choose the check in as a major (public) or minor (draft) version. 

i. Exit SharePoint Designer 2007. 

 


